LP#1603708: Remove support for Ubuntu 12.04 Precise
[working/Evergreen.git] / Open-ILS / src / extras / Makefile.install
1 # ---------------------------------------------------------------------
2 # Author: Bill Erickson <erickson@esilibrary.com>
3 # Author: Dan Scott <dscott@laurentian.ca>
4 #
5 # Makefile to install prerequisites for OpenSRF and Evergreen
6 #
7 # Currently supports Debian (jessie, wheezy), Ubuntu (12.04), 
8 # Ubuntu (14.04), Ubuntu (16.04), and Fedora (16 and 17).
9 #
10 # Installs Perl prereqs, libdbi, libdbi-drivers, and libyaz
11 #
12 # usage:
13 #       make -f Makefile.install debian-jessie
14 #       - or -
15 #       make -f Makefile.install debian-wheezy
16 #       - or -
17 #       make -f Makefile.install ubuntu-trusty
18 #       - or -
19 #       make -f Makefile.install ubuntu-xenial
20 #       - or -
21 #       make -f Makefile.install fedora
22 #
23 # ---------------------------------------------------------------------
24
25 # variables shared by all installers
26
27 # Make any assumptions about the shell being used explicit
28 export SHELL=/bin/bash 
29
30 export LIBNET_Z3950_SIMPLESERVER=Net-Z3950-SimpleServer-1.15
31 export LIBNET_Z3950_SIMPLESERVER_URL=http://ftp.indexdata.dk/pub/simpleserver/$(LIBNET_Z3950_SIMPLESERVER)
32
33 # The libdbi sources can be fetched from sourceforge.net.  They are stored on
34 # the open-ils.org site now for ease of direct linking
35 export LIBDBI=libdbi-0.8.3
36 export LIBDBI_DRIVERS=libdbi-drivers-0.8.3
37 export LIBDBI_HOST=http://open-ils.org/~denials/evergreen
38
39 # some OSes require a source install of NodeJS.
40 # NOTE: Deprecate me with wheezy
41 export NODEJS_SOURCE_VERSION=v0.10.28
42
43 # As this Makefile is designed to be used by a make process running as
44 # root, this will avoid problems on some systems when tar extracts
45 # files and tries to give them the same UID/GID as they have in their
46 # archives, but those accounts don't exist on the local system.
47 #
48 # e.g, libdbi has files set 1000/1000. On most systems, there's a user
49 # and a group with these IDs, but there can be systems where nothing
50 # uses those IDs, and where tar fails with e.g. 'tar: libdbi-0.8.3:
51 # Cannot change ownership to uid 1000, gid 1000: Invalid argument'
52 #
53 export TAR_OPTIONS=--no-same-owner --no-same-permissions
54
55 # ----------------------------------------------------------------------------
56
57 # avoid hard-coding the path to related makefiles
58 DIR = $(dir $(lastword $(MAKEFILE_LIST)))/install
59
60 all:
61         @echo "please specify an OS" && exit 0
62 debian-jessie:
63         @make -f $(DIR)/Makefile.debian-jessie
64 debian-wheezy:
65         @make -f $(DIR)/Makefile.debian-wheezy
66 ubuntu-xenial:
67         @make -f $(DIR)/Makefile.ubuntu-xenial
68 ubuntu-trusty:
69         @make -f $(DIR)/Makefile.ubuntu-trusty
70 fedora:
71         @make -f $(DIR)/Makefile.fedora
72
73 postgres-server-debian-jessie:
74         @make -f $(DIR)/Makefile.debian-jessie install_postgres_server
75 postgres-server-debian-wheezy:
76         @make -f $(DIR)/Makefile.debian-wheezy install_postgres_server
77 postgres-server-ubuntu-xenial:
78         @make -f $(DIR)/Makefile.ubuntu-xenial install_postgres_server
79 postgres-server-ubuntu-trusty:
80         @make -f $(DIR)/Makefile.ubuntu-trusty install_postgres_server
81 postgres-server-fedora:
82         @make -f $(DIR)/Makefile.fedora install_postgres_server
83
84 ubuntu-xenial-developer:
85         @make -f $(DIR)/Makefile.ubuntu-xenial install_developer
86 ubuntu-trusty-developer:
87         @make -f $(DIR)/Makefile.ubuntu-trusty install_developer
88 debian-jessie-developer:
89         @make -f $(DIR)/Makefile.debian-jessie install_developer
90 debian-wheezy-developer:
91         @make -f $(DIR)/Makefile.debian-wheezy install_developer
92
93 ubuntu-xenial-packager:
94         @make -f $(DIR)/Makefile.ubuntu-xenial install_packager
95 ubuntu-trusty-packager:
96         @make -f $(DIR)/Makefile.ubuntu-trusty install_packager
97 debian-jessie-packager:
98         @make -f $(DIR)/Makefile.debian-jessie install_packager
99 debian-wheezy-packager:
100         @make -f $(DIR)/Makefile.debian-wheezy install_packager
101
102 # vim:noet:sw=4:ts=4: