e3055ad055680316e2e1283fd05b08a8e69c5ccf
[Evergreen.git] / Open-ILS / src / extras / install / Makefile.debian-jessie
1 # install files for Debian Wheezy
2
3 DIR = $(dir $(lastword $(MAKEFILE_LIST)))
4
5 export DEB_PGSQL_COMMON_MODS = \
6         gcc \
7         libbusiness-isbn-perl \
8         libjson-xs-perl \
9         liblibrary-callnumber-lc-perl \
10         libmarc-record-perl \
11         libmarc-xml-perl \
12         librose-uri-perl \
13         libuuid-tiny-perl \
14         libxml-libxml-perl \
15         libxml-libxslt-perl
16
17 export DEBS = \
18         $(DEB_PGSQL_COMMON_MODS) \
19         apache2-prefork-dev\
20         aspell\
21         aspell-en\
22         libbusiness-creditcard-perl\
23         libbusiness-isbn-data-perl\
24         libbusiness-issn-perl\
25         libbusiness-onlinepayment-authorizenet-perl\
26         libbusiness-onlinepayment-payflowpro-perl\
27         libbusiness-onlinepayment-perl\
28         libdate-manip-perl\
29         libdatetime-format-builder-perl\
30         libdatetime-format-iso8601-perl\
31         libdatetime-format-mail-perl\
32         libdatetime-perl\
33         libdatetime-set-perl\
34         libdatetime-timezone-perl\
35         libdbd-pg-perl\
36         libdbd-pgsql\
37         libdbi-dev\
38         libdbi1\
39         libemail-simple-perl\
40         libexcel-writer-xlsx-perl\
41         libgd-graph3d-perl\
42         liblocale-maketext-lexicon-perl\
43         liblog-log4perl-perl\
44         libmarc-charset-perl \
45         libncurses5-dev\
46         libnet-ip-perl\
47         libnet-ldap-perl \
48         libnet-server-perl\
49         libnet-ssh2-perl\
50         libnet-z3950-simple2zoom-perl\
51         libnet-z3950-simpleserver-perl\
52         libnet-z3950-zoom-perl \
53         libnspr4-dev\
54         libole-storage-lite-perl\
55         libparent-perl\
56         libpq5\
57         libpq-dev\
58         librpc-xml-perl\
59         libsru-perl\
60         libssh2-1-dev\
61         libtemplate-plugin-posix-perl\
62         libtest-warn-perl\
63         libtest-output-perl\
64         libtext-aspell-perl\
65         libtext-csv-perl\
66         libuniversal-require-perl\
67         libunix-syslog-perl\
68         libyaz-dev\
69         postgresql-client-9.4\
70         libsoap-lite-perl\
71         libbz2-dev\
72         libparse-recdescent-perl\
73         yaz
74
75 export DEB_APACHE_MODS = \
76     expires\
77     include\
78     proxy\
79     proxy_http\
80     rewrite\
81     cgi
82
83 export DEB_APACHE_DISMODS = \
84     deflate
85
86 export CPAN_MODULES = \
87         Business::OnlinePayment::PayPal \
88         Email::Send
89
90 export CPAN_MODULES_FORCE = \
91         Business::Stripe \
92         Class::DBI::Frozen::301
93
94 PGSQL_SERVER_DEBS_94 = \
95         $(DEB_PGSQL_COMMON_MODS) \
96         postgresql-9.4 \
97         postgresql-contrib-9.4 \
98         postgresql-plperl-9.4 \
99         postgresql-server-dev-9.4
100
101 # note: some prereqs are repeated in the developer/packager 
102 # sections to support building Evergreen packages on servers
103 # where Evergreen and its prereqs are not installed.
104
105 # nodejs-legacy creates a symlink for /usr/bin/node -> /usr/bin/nodejs
106 # which is needed by our npm-installed packages
107 DEVELOPER_DEBS = \
108         automake \
109         autoconf \
110         libtool \
111         nodejs-legacy \
112         npm
113
114 PACKAGER_DEBS = \
115         libtemplate-perl \
116         liblocale-maketext-lexicon-perl \
117         asciidoc \
118         source-highlight \
119         translate-toolkit \
120         python-dev \
121         python-levenshtein \
122         python-polib \
123         python-setuptools \
124         python-simplejson \
125         python-lxml \
126         zip \
127         unzip \
128         bzr \
129         nsis
130
131 all:
132         make -f $(DIR)/Makefile.debian install_debs
133         make -f $(DIR)/Makefile.common install_cpan
134         make -f $(DIR)/Makefile.common install_cpan_force
135         make -f $(DIR)/Makefile.debian debian_sys_config
136
137 install_postgres_server:
138         make -f $(DIR)/Makefile.debian DEBS="$(PGSQL_SERVER_DEBS_94)"
139
140 # note: if/when grunt-cli and bower are available as 
141 # packages, use the packaged versions instead.
142 install_developer:
143         make -f $(DIR)/Makefile.debian DEBS="$(DEVELOPER_DEBS)"
144         npm update
145         npm install -g grunt-cli
146         npm install -g bower
147
148 install_packager: install_developer
149         make -f $(DIR)/Makefile.debian DEBS="$(PACKAGER_DEBS)"
150
151 clean:
152         make -f $(DIR)/Makefile.common clean
153         make -f $(DIR)/Makefile.debian clean
154
155 # vim:noet:sw=4:ts=4: