libxml2 and libxslt1 Python modules are abnormal - remove them from requires list
[OpenSRF.git] / src / python / setup.py
1 #!/usr/bin/env python
2
3 from setuptools import setup
4
5 setup(name='OpenSRF',
6     version='1.0',
7     install_requires=[
8         'dnspython', # required by pyxmpp
9         'python_memcached',
10         'pyxmpp>=1.0.0',
11         'simplejson>=1.7.1'
12     ],
13     dependency_links = [
14         "http://pyxmpp.jajcus.net/downloads/"
15     ],
16     description='OpenSRF Python Modules',
17     author='Bill Erickson',
18     author_email='erickson@esilibrary.com',
19     license="GPL",
20     url='http://www.open-ils.org/',
21     packages=['osrf'],
22     scripts=['srfsh.py']
23 )