Add upgrading to 2.0 Documentation.