Pulling in 2.4.1 upgrade script