Version upgrade script from 2.4-alpha1