Improve Fedora prereqs and instructions
authorDan Scott <dan@coffeecode.net>
Sun, 3 Jun 2012 05:09:26 +0000 (01:09 -0400)
committerDan Scott <dan@coffeecode.net>
Sun, 3 Jun 2012 05:19:43 +0000 (01:19 -0400)
Fedora 16 and 17 need the makensis package.

As well, make the Makefile.install target "fedora" to match the OpenSRF
target, and adjust the docs accordingly. This should lead to fewer
changes in the future as Fedora 18, 19, etc roll out.

Signed-off-by: Dan Scott <dan@coffeecode.net>
Open-ILS/src/extras/Makefile.install
docs/installation/server_installation.txt

index aeb84f3..9d9c6c3 100644 (file)
@@ -4,7 +4,9 @@
 #
 # Makefile to install prerequisites for OpenSRF and Evergreen
 #
 #
 # Makefile to install prerequisites for OpenSRF and Evergreen
 #
-# Currently supports Debian (squeeze), Ubuntu (10.04), Ubuntu (12.04) and Fedora (16).
+# Currently supports Debian (squeeze), Ubuntu (10.04), Ubuntu (12.04) and
+# Fedora (16 and 17).
+#
 # Installs Perl prereqs, libjs with Perl wrapper, libdbi, libdbi-drivers, and libyaz
 #
 # usage:
 # Installs Perl prereqs, libjs with Perl wrapper, libdbi, libdbi-drivers, and libyaz
 #
 # usage:
@@ -14,7 +16,7 @@
 #      - or -
 #      make -f Makefile.install ubuntu-precise
 #      - or -
 #      - or -
 #      make -f Makefile.install ubuntu-precise
 #      - or -
-#      make -f Makefile.install fedora16
+#      make -f Makefile.install fedora
 #
 # ---------------------------------------------------------------------
  
 #
 # ---------------------------------------------------------------------
  
@@ -122,6 +124,7 @@ FEDORA_RPMS = \
        libssh2-devel \
        libyaz \
        libyaz-devel \
        libssh2-devel \
        libyaz \
        libyaz-devel \
+       mingw32-nsiswrapper \
        mod_ssl \
        ncurses-devel \
        ncurses-libs \
        mod_ssl \
        ncurses-devel \
        ncurses-libs \
@@ -152,7 +155,7 @@ FEDORA_RPMS = \
 
 # Note: B:O:AuthorizeNet 3.21 fails with https://rt.cpan.org/Public/Bug/Display.html?id=55172
 # Should be fixed in 3.22
 
 # Note: B:O:AuthorizeNet 3.21 fails with https://rt.cpan.org/Public/Bug/Display.html?id=55172
 # Should be fixed in 3.22
-# MARC::Record 2.0.1 is required but only 2.0.0 is packaged
+# MARC::Record 2.0.1+ is required but only 2.0.0 is packaged
 FEDORA_CPAN = \
        Business::OnlinePayment \
        Business::OnlinePayment::AuthorizeNet \
 FEDORA_CPAN = \
        Business::OnlinePayment \
        Business::OnlinePayment::AuthorizeNet \
@@ -261,7 +264,7 @@ all:
 # these should be the same for any distro
 install: install_cpan install_js_sm install_cpan_force
 
 # these should be the same for any distro
 install: install_cpan install_js_sm install_cpan_force
 
-fedora16: install_fedora_rpms install_cpan_fedora install_cpan_marc install
+fedora: install_fedora_rpms install_cpan_fedora install_cpan_marc install
 
 debian-squeeze: squeeze generic_debian
 squeeze: install_pgsql_client_backport_debs_91  install_extra_debs_squeeze
 
 debian-squeeze: squeeze generic_debian
 squeeze: install_pgsql_client_backport_debs_91  install_extra_debs_squeeze
index c7585c0..991eece 100644 (file)
@@ -103,13 +103,13 @@ add-apt-repository ppa:pitti/postgresql
 +
   * Ubuntu Precise comes with PostgreSQL 9, so no additional steps are required.
 +
 +
   * Ubuntu Precise comes with PostgreSQL 9, so no additional steps are required.
 +
-  * Fedora 16 comes with PostgreSQL 9, so no additional steps are required.
+  * Fedora comes with PostgreSQL 9, so no additional steps are required.
 +
 3. On Debian and Ubuntu, run `aptitude update` as the *root* Linux account to
    retrieve the new packages from the backports repository.
 4. Issue the following commands as the *root* Linux account to install
    prerequisites using the `Makefile.install` prerequisite installer,
 +
 3. On Debian and Ubuntu, run `aptitude update` as the *root* Linux account to
    retrieve the new packages from the backports repository.
 4. Issue the following commands as the *root* Linux account to install
    prerequisites using the `Makefile.install` prerequisite installer,
-   substituting `debian-squeeze`, `fedora16`, `ubuntu-lucid`, or
+   substituting `debian-squeeze`, `fedora`, `ubuntu-lucid`, or
    `ubuntu-precise` for <osname> below:
 +
 [source, bash]
    `ubuntu-precise` for <osname> below:
 +
 [source, bash]
@@ -329,7 +329,7 @@ make -f Open-ILS/src/extras/Makefile.install install_pgsql_server_debs_91
 You can install the packages required by Fedora on the machine of your choice
 using the following commands as the *root* Linux account:
 
 You can install the packages required by Fedora on the machine of your choice
 using the following commands as the *root* Linux account:
 
-.(Fedora 16) Installing PostgreSQL server packages
+.(Fedora) Installing PostgreSQL server packages
 [source, bash]
 ------------------------------------------------------------------------------
 make -f Open-ILS/src/extras/Makefile.install install_fedora_pgsql_server
 [source, bash]
 ------------------------------------------------------------------------------
 make -f Open-ILS/src/extras/Makefile.install install_fedora_pgsql_server
@@ -351,7 +351,7 @@ cpan MARC::File::XML
 cpan UUID::Tiny
 ------------------------------------------------------------------------------
 
 cpan UUID::Tiny
 ------------------------------------------------------------------------------
 
-.(Fedora 16) Installing additional Perl modules on a standalone PostgreSQL 9 server
+.(Fedora) Installing additional Perl modules on a standalone PostgreSQL 9 server
 [source, bash]
 ------------------------------------------------------------------------------
 yum install gcc perl-XML-LibXML perl-XML-LibXSLT perl-Business-ISBN
 [source, bash]
 ------------------------------------------------------------------------------
 yum install gcc perl-XML-LibXML perl-XML-LibXSLT perl-Business-ISBN