update server upgrade instructions for 2.12.0
authorGalen Charlton <gmc@equinoxinitiative.org>
Wed, 22 Mar 2017 18:05:14 +0000 (14:05 -0400)
committerGalen Charlton <gmc@equinoxinitiative.org>
Wed, 22 Mar 2017 18:05:14 +0000 (14:05 -0400)
Signed-off-by: Galen Charlton <gmc@equinoxinitiative.org>
docs/installation/server_upgrade.txt

index 787738c..2fb063c 100644 (file)
@@ -8,7 +8,7 @@ Software Prerequisites
 
   * **PostgreSQL**: Version 9.4 is recommended.
     The minimum supported version is 9.3.
-  * **Linux**: Evergreen 2.12-rc has been tested on Debian Jessie (8.0),
+  * **Linux**: Evergreen 2.12.0 has been tested on Debian Jessie (8.0),
     Debian Wheezy (7.0), Ubuntu Xenial Xerus (16.04),
     and Ubuntu Trusty Tahr (14.04).
     If you are running an older version of these distributions, you may want
@@ -44,12 +44,12 @@ osrf_control --localhost --stop-all
  .. Back up the /openils directory.
 . Upgrade OpenSRF. Download and install the latest version of OpenSRF from
 the https://evergreen-ils.org/opensrf-downloads/[OpenSRF download page].
-. As the *opensrf* user, download and extract Evergreen 2.12-rc:
+. As the *opensrf* user, download and extract Evergreen 2.12.0:
 +
 [source, bash]
 -----------------------------------------------
-wget https://evergreen-ils.org/downloads/Evergreen-ILS-2.12-rc.tar.gz
-tar xzf Evergreen-ILS-2.12-rc.tar.gz
+wget https://evergreen-ils.org/downloads/Evergreen-ILS-2.12.0.tar.gz
+tar xzf Evergreen-ILS-2.12.0.tar.gz
 -----------------------------------------------
 +
 [NOTE]
@@ -59,7 +59,7 @@ For the latest edition of Evergreen, check the https://evergreen-ils.org/egdownl
 +
 [source, bash]
 ---------------------------------------------
-cd /home/opensrf/Evergreen-ILS-2.12-rc
+cd /home/opensrf/Evergreen-ILS-2.12.0
 ---------------------------------------------
 +
 On the next command, replace `[distribution]` with one of these values for your
@@ -83,7 +83,7 @@ make -f Open-ILS/src/extras/Makefile.install [distribution]
 +
 [source, bash]
 ------------------------------------------------------------
-cd /home/opensrf/Evergreen-ILS-2.12-rc
+cd /home/opensrf/Evergreen-ILS-2.12.0
 PATH=/openils/bin:$PATH ./configure --prefix=/openils --sysconfdir=/openils/conf
 make
 ------------------------------------------------------------
@@ -94,7 +94,7 @@ These instructions assume that you have also installed OpenSRF under /openils/.
 +
 [source, bash]
 ------------------------------------------------------------
-cd /home/opensrf/Evergreen-ILS-2.12-rc
+cd /home/opensrf/Evergreen-ILS-2.12.0
 make STAFF_CLIENT_STAMP_ID=rel_2_12_rc install
 ------------------------------------------------------------
 +
@@ -131,7 +131,7 @@ Copying these configuration files will remove any customizations you have made t
 +
 [source, bash]
 -------------------------------------------------------------------------
-cd /home/opensrf/Evergreen-ILS-2.12-rc
+cd /home/opensrf/Evergreen-ILS-2.12.0
 perl Open-ILS/src/support-scripts/eg_db_config --update-config --service all \
 --create-offline --database evergreen --host localhost --user evergreen --password evergreen
 -------------------------------------------------------------------------
@@ -155,21 +155,21 @@ The diff command can be used to show the differences between the distribution ve
 +
 [source, bash]
 ----------------------------------------------------------
-cp /home/opensrf/Evergreen-ILS-2.12-rc/Open-ILS/examples/apache/eg_startup /etc/apache2/eg_startup
+cp /home/opensrf/Evergreen-ILS-2.12.0/Open-ILS/examples/apache/eg_startup /etc/apache2/eg_startup
 ----------------------------------------------------------
 +
 .. Update /etc/apache2/eg_vhost.conf by copying the example from Open-ILS/examples/apache/eg_vhost.conf.
 +
 [source, bash]
 ----------------------------------------------------------
-cp /home/opensrf/Evergreen-ILS-2.12-rc/Open-ILS/examples/apache/eg_vhost.conf /etc/apache2/eg_vhost.conf
+cp /home/opensrf/Evergreen-ILS-2.12.0/Open-ILS/examples/apache/eg_vhost.conf /etc/apache2/eg_vhost.conf
 ----------------------------------------------------------
 +
 .. Update /etc/apache2/sites-available/eg.conf by copying the example from Open-ILS/examples/apache/eg.conf.
 +
 [source, bash]
 ----------------------------------------------------------
-cp /home/opensrf/Evergreen-ILS-2.12-rc/Open-ILS/examples/apache/eg.conf /etc/apache2/sites-available/eg.conf
+cp /home/opensrf/Evergreen-ILS-2.12.0/Open-ILS/examples/apache/eg.conf /etc/apache2/sites-available/eg.conf
 ----------------------------------------------------------
 
 Upgrade the Evergreen database schema
@@ -192,7 +192,7 @@ anything goes wrong during the upgrade.
 =============
 Evergreen provides incremental upgrade scripts that allow you to upgrade
 from one minor version to the next until you have the current version of
-the schema. For example, if you want to upgrade from 2.5.1 to 2.12-rc, you
+the schema. For example, if you want to upgrade from 2.5.1 to 2.12.0, you
 would run the following upgrade scripts:
 
 - 2.5.1-2.5.2-upgrade-db.sql
@@ -225,14 +225,14 @@ would run the following upgrade scripts:
 - 2.11.0-2.11.1-upgrade-db.sql
 - 2.11.1-2.11.2-upgrade-db.sql
 - 2.11.2-2.11.3-upgrade-db.sql
-- 2.11.3-2.12-rc-upgrade-db.sql (this is a major version upgrade)
+- 2.11.3-2.12.0-upgrade-db.sql (this is a major version upgrade)
 
 Note that you do *not* want to run additional 2.5 scripts to upgrade to the
 newest version of 2.5, since currently there is no automated way to upgrade
 from 2.5.4+ to 2.6. Only upgrade as far as necessary to reach the major
 version upgrade script (in this example, as far as 2.5.3).
 
-To upgrade across multiple major versions (e.g. from 2.3.0 to 2.12-rc), use
+To upgrade across multiple major versions (e.g. from 2.3.0 to 2.12.0), use
 the same logic to utilize the provided major version upgrade scripts. For
 example:
 
@@ -253,7 +253,7 @@ example:
 - (run all incremental scripts from 2.10.0 to 2.10.7)
 - 2.10.7-2.11.0-upgrade-db.sql
 - (run all incremental scripts from 2.11.0 to 2.11.3)
-- 2.11.3-2.12-rc-upgrade-db.sql
+- 2.11.3-2.12.0-upgrade-db.sql
 
 =============
 
@@ -268,8 +268,8 @@ as a user with the ability to connect to the database server.
 
 [source, bash]
 ----------------------------------------------------------
-cd /home/opensrf/Evergreen-ILS-2.12-rc/Open-ILS/src/sql/Pg
-psql -U evergreen -h localhost -f version-upgrade/2.11.3-2.12-rc-upgrade-db.sql evergreen
+cd /home/opensrf/Evergreen-ILS-2.12.0/Open-ILS/src/sql/Pg
+psql -U evergreen -h localhost -f version-upgrade/2.11.3-2.12.0-upgrade-db.sql evergreen
 ----------------------------------------------------------
 
 [TIP]