Simple 1-line feature for EDI translator
authoratz <atz@dcc99617-32d9-48b4-a31d-7c20da2025e4>
Wed, 4 Aug 2010 03:56:35 +0000 (03:56 +0000)
committeratz <atz@dcc99617-32d9-48b4-a31d-7c20da2025e4>
Wed, 4 Aug 2010 03:56:35 +0000 (03:56 +0000)
Allows us to know what the effective version of openils-mapper is.

git-svn-id: svn://svn.open-ils.org/ILS/trunk@17070 dcc99617-32d9-48b4-a31d-7c20da2025e4

Open-ILS/src/edi_translator/edi_webrick.rb

index b1386a3..435b31b 100755 (executable)
@@ -88,6 +88,7 @@ end
 
 # create a servlet to handle XML-RPC requests:
 servlet = XMLRPC::WEBrickServlet.new
 
 # create a servlet to handle XML-RPC requests:
 servlet = XMLRPC::WEBrickServlet.new
+servlet.add_handler("mapper_version") { OpenILS::Mapper::VERSION }
 servlet.add_handler("upper_case") { |a_string| a_string.upcase   }
 servlet.add_handler("lower_case") { |a_string| a_string.downcase }
 servlet.add_handler("edi2json"  ) { |a_string|
 servlet.add_handler("upper_case") { |a_string| a_string.upcase   }
 servlet.add_handler("lower_case") { |a_string| a_string.downcase }
 servlet.add_handler("edi2json"  ) { |a_string|