LP 1542495: Release Notes and Sample Config Change.
authorJason Stephenson <jason@sigio.com>
Sun, 8 Jan 2017 00:49:12 +0000 (19:49 -0500)
committerGalen Charlton <gmc@equinoxinitiative.org>
Fri, 11 Aug 2017 14:00:11 +0000 (10:00 -0400)
In addition to adding the release note file, we alter the location of
the encoding element in oils_sip.xml.example to the new, recommended
location.

Signed-off-by: Jason Stephenson <jason@sigio.com>
Signed-off-by: Martha Driscoll <driscoll@noblenet.org>
Signed-off-by: Galen Charlton <gmc@equinoxinitiative.org>
Open-ILS/examples/oils_sip.xml.example
docs/RELEASE_NOTES_NEXT/SIP/LP1542495-Requires-SIPServer-Upgrade.adoc [new file with mode: 0644]

index c3843e3..57ebda4 100644 (file)
                                timeout="600" 
                                retries="3"/>
        
                                timeout="600" 
                                retries="3"/>
        
+                       <!-- The default encoding defined in the SIP specification is -->
+                       <!-- ASCII, which isn't great for French, Spanish, Armenian. -->
+                       <!-- You can specify a different encoding here, based on the -->
+                       <!-- encodings supported by your SIP client and your Encode -->
+                       <!-- module; run the following command to get a list of supported -->
+                       <!-- encodings: -->
+                       <!--   perl -MEncode -le "print for Encode->encodings(':all')" -->
+
+                       <!-- UTF-8 is the recommended encoding if your SIP client supports it -->
+                       <encoding>ascii</encoding>
+
                        <!-- implementation specific config options go here -->
                        <implementation_config>
                                <bootstrap>SYSCONFDIR/opensrf_core.xml</bootstrap>
                                <currency>USD</currency>
 
                        <!-- implementation specific config options go here -->
                        <implementation_config>
                                <bootstrap>SYSCONFDIR/opensrf_core.xml</bootstrap>
                                <currency>USD</currency>
 
-                               <!-- The default encoding defined in the SIP specification is -->
-                               <!-- ASCII, which isn't great for French, Spanish, Armenian. -->
-                               <!-- You can specify a different encoding here, based on the -->
-                               <!-- encodings supported by your SIP client and your Encode -->
-                               <!-- module; run the following command to get a list of supported -->
-                               <!-- encodings: -->
-                               <!--   perl -MEncode -le "print for Encode->encodings(':all')" -->
-
-                               <!-- UTF-8 is the recommended encoding if your SIP client supports it -->
-                               <encoding>ascii</encoding>
-
                                <!-- These defines what this SIP code has the ability to support -->
                                <supports>
                                        <item name='magnetic media' value='true'/>
                                <!-- These defines what this SIP code has the ability to support -->
                                <supports>
                                        <item name='magnetic media' value='true'/>
diff --git a/docs/RELEASE_NOTES_NEXT/SIP/LP1542495-Requires-SIPServer-Upgrade.adoc b/docs/RELEASE_NOTES_NEXT/SIP/LP1542495-Requires-SIPServer-Upgrade.adoc
new file mode 100644 (file)
index 0000000..2b40037
--- /dev/null
@@ -0,0 +1,34 @@
+SIP Bugfix Requires SIPServer Upgrade
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
+The fix for Launchpad Bug 1542495: "OpenILS::SIP::clean_text() can
+crash" requires that you also upgrade SIPServer with the fix for
+Launchpad Bug 1463943: "Non-ascii Unicode characters in messages cause
+SIP client problems."  This means that if you use SIP2 with Evergreen,
+you must also upgrade SIPServer to the latest commit in the git
+repository.  Conversely, if you upgrade SIPServer to the latest commit
+in git, you must also upgrade Evergreen or, at least, apply the patch
+for Launchpad Bug 1542495.  These two patches are complementary and
+cannot be applied independently of one another.
+
+SIP Bugfix Changes How Encoding Is Determined in Configuration
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
+The combined fix for the above mentioned SIP bugs alters the way that
+the output encoding is looked up in the configuration file (typically
+oils_sip.xml).  SIPServer now looks for the encoding in the following
+places:
+
+1. An +encoding+ attribute on the +account+ element for the currently active SIP account.
+2. The +encoding+ element that is a child of the +insitution+ element of the currently acctive SIP account.
+3. The +encoding+ element that is a child of the +implementation_config+ element that is itself a child of the +insitution+ element of the currently acctive SIP account.
+4. If none of the above exist, then ASCII encoding is used by default.
+
+Number 3 is provided to ease the transition to the new code.  It is
+the current location of the +encoding+ element in the sample
+configuration file and as such, where it is likely to be found in
+actual files.  It is recommended that you alter your configuration to
+move this element out of the +implementation_config+ element and into
+its parent +institution+ element.  SIPServer should *not* look into
+the implementation config, and this check may be removed at some time
+in the future.