Only one of these tests was valid, removing the bad one
[working/Evergreen.git] / Open-ILS / updates / manualupdate.html
1 #!/bin/bash
2 echo "Content-Type: text/html"
3 echo ""
4 if [ -f ../patch/manual.html ]; then
5         cat ../patch/manual.html
6         exit
7 fi
8 cat <<ENDHEADER
9 <html>
10 <head>
11 <title>Evergreen Staff Client</title>
12 </head>
13 <body>
14 <h1>Evergreen Staff Client</h1>
15 ENDHEADER
16 if [ -f ../patch/win/VERSION ]; then
17         echo "<h2>Windows</h2>"
18         VERSION=$(cat ../patch/win/VERSION)
19         if [ -f clients/${VERSION}_setup.exe ]; then
20                 echo "<p>An installer for Windows is available.</p>"
21                 echo "<p><a href=\"clients/${VERSION}_setup.exe\">Click here to download the installer (version $VERSION)</a></p>"
22         else
23                 echo "<p>No installer is currently available for Windows.</p>"
24         fi
25 fi
26 if [ -f ../patch/lin/VERSION ]; then
27         echo "<h2>Linux (32 bit)</h2>"
28         VERSION=$(cat ../patch/lin/VERSION)
29         if [ -f clients/${VERSION}_i686.tar.bz2 ]; then
30                 echo "<p>A 32 bit bundle for Linux is available.</p>"
31                 echo "<p><a href=\"clients/${VERSION}_i686.tar.bz2\">Click here to download the bundle (version $VERSION)</a></p>"
32         else
33                 echo "<p>No 32 bit bundle is currently available for Linux.</p>"
34         fi
35 fi
36 if [ -f ../patch/lin64/VERSION ]; then
37         echo "<h2>Linux (64 bit)</h2>"
38         VERSION=$(cat ../patch/lin64/VERSION)
39         if [ -f clients/${VERSION}_x86_64.tar.bz2 ]; then
40                 echo "<p>A 64 bit bundle for Linux is available.</p>"
41                 echo "<p><a href=\"clients/${VERSION}_x86_64.tar.bz2\">Click here to download the bundle (version $VERSION)</a></p>"
42         else
43                 echo "<p>No 64 bit bundle is currently available for Linux.</p>"
44         fi
45 fi
46
47 if [ -f ../patch/VERSION ]; then
48         echo "<h2>XULRunner App Bundle</h2>"
49         VERSION=$(cat ../patch/VERSION)
50         if [ -f clients/${VERSION}_client.xpi ]; then
51                 echo "<p>A XULRunner app bundle is available.</p>"
52                 echo "<p><a href=\"download/${VERSION}_client.xpi\">Click here to download the XULRunner app bundle (version $VERSION)</a></p>"
53                 echo "<p>This bundle can be installed via the --install-app command on xulrunner itself and should be compatible with all platforms XULRunner runs on.</p>"
54         else
55                 echo "<p>No XULRunner app bundle is currently available.</p>"
56         fi
57         echo "<h2>Firefox Extension</h2>"
58         if [ -f ${VERSION}_extension.xpi ]; then
59                 echo "<p>A Firefox Extension is available.</p>"
60                 echo "<p><a href=\"${VERSION}_extension.xpi\">Click here to install the extension (version $VERSION)</a>"
61         else
62                 echo "<p>No Firefox Extension is currently available.</p>"
63         fi
64 fi
65 cat <<ENDFOOTER
66 </body>
67 </html>
68 ENDFOOTER