Forward-port upgrade scripts from recent releases
[working/Evergreen.git] / Open-ILS / src / sql / Pg / version-upgrade / 2.4.2-2.4.3-upgrade-db.sql
1 --Upgrade Script for 2.4.2 to 2.4.3
2 \set eg_version '''2.4.3'''
3 BEGIN;
4 INSERT INTO config.upgrade_log (version, applied_to) VALUES ('2.4.3', :eg_version);
5 -- Evergreen DB patch 0825.data.bre_format.sql
6 --
7 -- Fix some templates that loop over bibs to not have duplicated/run-on titles
8 --
9
10 -- check whether patch can be applied
11 SELECT evergreen.upgrade_deps_block_check('0825', :eg_version);
12
13 -- I think we shy away from modifying templates on existing systems, but this seems pretty safe...
14 UPDATE
15     action_trigger.event_definition
16 SET
17     template = replace(template,'[% FOR cbreb IN target %]','[% FOR cbreb IN target %][% title = '''' %]')
18 WHERE
19     id IN (31,32);
20
21 COMMIT;