Make Evergreen Perl modules installable via Module::Build to match OpenSRF
[working/Evergreen.git] / Open-ILS / src / perlmods / lib / OpenILS / Application / Trigger / Validator / Acq.pm
1 package OpenILS::Application::Trigger::Validator::Acq;
2 use strict; use warnings;
3 # use OpenSRF::Utils::Logger qw/:logger/;
4
5 sub get_lineitem_from_req {
6     my($self, $env) = @_;
7     my $req = $env->{target};
8     return (ref $env->{target}->lineitem) ? 
9         $env->{target}->lineitem : 
10         $self->editor->retrieve_acq_lineitem($$env->{target}->lineitem);
11 }
12
13 1;