Add ISSN support to Syndetic AC handler
[working/Evergreen.git] / Open-ILS / src / extras / install / Makefile.debian-squeeze
1 # install files for Debian Squeeze
2
3 DIR = $(dir $(lastword $(MAKEFILE_LIST)))
4 APT_BACKPORT_TOOL = aptitude -t squeeze-backports -yq
5 APT_SAFE_TOOL = aptitude -P
6 APT_TOOL=aptitude -yq
7 YAZ=yaz-4.2.32
8 YAZ_HOST=http://ftp.indexdata.dk/pub/yaz
9
10
11 export DEBS = \
12         apache2-prefork-dev\
13         aspell\
14         aspell-en\
15         libbusiness-creditcard-perl\
16         libbusiness-isbn-data-perl\
17         libbusiness-isbn-perl\
18         libbusiness-issn-perl\
19         libbusiness-onlinepayment-authorizenet-perl\
20         libbusiness-onlinepayment-perl\
21         libdatetime-format-builder-perl\
22         libdatetime-format-iso8601-perl\
23         libdatetime-format-mail-perl\
24         libdatetime-perl\
25         libdatetime-set-perl\
26         libdatetime-timezone-perl\
27         libdbd-pg-perl\
28         libemail-send-perl\
29         libemail-simple-perl\
30         libgd-graph3d-perl\
31         liblocale-maketext-lexicon-perl\
32         liblog-log4perl-perl\
33         libmarc-charset-perl \
34         libmarc-record-perl\
35         libmarc-xml-perl \
36         libncurses5-dev\
37         libnet-ip-perl\
38         libnet-ldap-perl \
39         libnet-server-perl\
40         libnet-ssh2-perl\
41         libnet-z3950-zoom-perl \
42         libnspr4-dev\
43         libole-storage-lite-perl\
44         libparent-perl\
45         libspreadsheet-writeexcel-perl\
46         libssh2-1-dev\
47         libtest-warn-perl\
48         libtext-aspell-perl\
49         libtext-csv-perl\
50         libuniversal-require-perl\
51         libunix-syslog-perl\
52     libuuid-tiny-perl\
53         libyaz-dev\
54         libsoap-lite-perl\
55         libbz2-dev\
56         yaz
57
58 export DEB_APACHE_MODS = \
59     expires\
60     include\
61     proxy\
62     proxy_http\
63     rewrite
64
65 export DEB_APACHE_DISMODS = \
66     deflate
67
68 export CPAN_MODULES = \
69         Business::OnlinePayment::PayPal \
70         Library::CallNumber::LC \
71         Net::Z3950::Simple2ZOOM \
72         RPC::XML \
73         Template::Plugin::POSIX \
74         SRU \
75         Rose::URI \
76         Safe
77
78 export CPAN_MODULES_FORCE = \
79         Class::DBI::Frozen::301
80
81 PGSQL_SERVER_DEBS_91 = \
82         postgresql-9.1 \
83         postgresql-contrib-9.1 \
84         postgresql-plperl-9.1 \
85         postgresql-server-dev-9.1
86
87 PGSQL_CLIENT_DEBS_91 = \
88         libpq5 \
89         libpq-dev \
90         postgresql-client-9.1
91
92
93 all: install_pgsql_client_backport_debs_91 install_yaz
94         make -f $(DIR)/Makefile.debian install_debs
95         make -f $(DIR)/Makefile.debian test_for_libdbi_pkg
96         make -f $(DIR)/Makefile.common install_net_z3950_simpleserver
97         make -f $(DIR)/Makefile.common install_cpan
98         make -f $(DIR)/Makefile.common install_cpan_force
99         make -f $(DIR)/Makefile.common install_libdbi
100         make -f $(DIR)/Makefile.debian install_js_sm
101         make -f $(DIR)/Makefile.debian debian_sys_config
102
103 install_yaz:
104         if [ ! -d $(YAZ) ]; then wget $(YAZ_HOST)/$(YAZ).tar.gz; fi;
105         tar xzf $(YAZ).tar.gz
106         cd $(YAZ) && ./configure && make && make install && ldconfig
107
108 install_postgres_server:
109         $(APT_BACKPORT_TOOL) install $(PGSQL_SERVER_DEBS_91)
110
111 install_pgsql_client_backport_debs_91:
112         @if [ `$(APT_TOOL) versions libpq5 | grep ^i|sed 's/^i[ \t]*//'|cut -d. -f1` -eq 8 ]; \
113                 then \
114                 echo -e "libpq5 / libpq-dev are installed as part of OpenSRF (a dependency" \
115                 "of apache2-prefork-dev), but these are the 8.4 versions and they" \
116                 "conflict with the 9.1 versions - so remove them, install the pinned" \
117                 "backports of 9.1, then reinstall the apache2-prefork-dev package.\n\n" \
118                 "**WARNING**: Saying 'Yes' to this step will _remove_ any PostgreSQL" \
119                 "databases that might currently exist on this machine." && \
120                 $(APT_SAFE_TOOL) remove libpq5 libpq-dev ; \
121         fi
122         $(APT_BACKPORT_TOOL) install $(PGSQL_CLIENT_DEBS_91)
123         $(APT_TOOL) install apache2-prefork-dev
124
125 clean:
126         make -f $(DIR)/Makefile.common clean
127         make -f $(DIR)/Makefile.debian clean
128
129 # vim:noet:sw=4:ts=4: