a5294b46437a4575179fd6f9482964e69f045795
[working/Evergreen.git] / Open-ILS / src / extras / install / Makefile.debian-jessie
1 # install files for Debian Wheezy
2
3 DIR = $(dir $(lastword $(MAKEFILE_LIST)))
4
5 export DEB_PGSQL_COMMON_MODS = \
6         gcc \
7         libbusiness-isbn-perl \
8         libjson-xs-perl \
9         liblibrary-callnumber-lc-perl \
10         libmarc-record-perl \
11         libmarc-xml-perl \
12         librose-uri-perl \
13         libuuid-tiny-perl \
14         libxml-libxml-perl \
15         libxml-libxslt-perl
16
17 export DEBS = \
18         $(DEB_PGSQL_COMMON_MODS) \
19         apache2-prefork-dev\
20         aspell\
21         aspell-en\
22         libbusiness-creditcard-perl\
23         libbusiness-isbn-data-perl\
24         libbusiness-issn-perl\
25         libbusiness-onlinepayment-authorizenet-perl\
26         libbusiness-onlinepayment-perl\
27         libdate-manip-perl\
28         libdatetime-format-builder-perl\
29         libdatetime-format-iso8601-perl\
30         libdatetime-format-mail-perl\
31         libdatetime-perl\
32         libdatetime-set-perl\
33         libdatetime-timezone-perl\
34         libdbd-pg-perl\
35         libemail-send-perl\
36         libemail-simple-perl\
37         libgd-graph3d-perl\
38         liblocale-maketext-lexicon-perl\
39         liblog-log4perl-perl\
40         libmarc-charset-perl \
41         libncurses5-dev\
42         libnet-ip-perl\
43         libnet-ldap-perl \
44         libnet-server-perl\
45         libnet-ssh2-perl\
46         libnet-z3950-simple2zoom-perl\
47         libnet-z3950-simpleserver-perl\
48         libnet-z3950-zoom-perl \
49         libnspr4-dev\
50         libole-storage-lite-perl\
51         libparent-perl\
52         libpq5\
53         libpq-dev\
54         librpc-xml-perl\
55         libspreadsheet-writeexcel-perl\
56         libsru-perl\
57         libssh2-1-dev\
58         libtest-warn-perl\
59         libtest-output-perl\
60         libtext-aspell-perl\
61         libtext-csv-perl\
62         libuniversal-require-perl\
63         libunix-syslog-perl\
64         libyaz-dev\
65         postgresql-client-9.3\
66         libsoap-lite-perl\
67         libbz2-dev\
68         libparse-recdescent-perl\
69         yaz
70
71 export DEB_APACHE_MODS = \
72     expires\
73     include\
74     proxy\
75     proxy_http\
76     rewrite
77
78 export DEB_APACHE_DISMODS = \
79     deflate
80
81 export CPAN_MODULES = \
82         Business::OnlinePayment::PayPal \
83         Template::Plugin::POSIX \
84         Safe
85
86 export CPAN_MODULES_FORCE = \
87         Business::Stripe \
88         Class::DBI::Frozen::301
89
90 PGSQL_SERVER_DEBS_93 = \
91         $(DEB_PGSQL_COMMON_MODS) \
92         postgresql-9.3 \
93         postgresql-contrib-9.3 \
94         postgresql-plperl-9.3 \
95         postgresql-server-dev-9.3
96
97 # nodejs-legacy creates a symlink for /usr/bin/node -> /usr/bin/nodejs
98 # which is needed by our npm-installed packages
99 DEVELOPER_DEBS = \
100         nodejs-legacy \
101         npm
102
103 PACKAGER_DEBS = \
104         translate-toolkit \
105         python-dev \
106         python-levenshtein \
107         python-polib \
108         python-setuptools \
109         python-simplejson \
110         python-lxml \
111         zip \
112         unzip \
113         nsis
114
115 all:
116         make -f $(DIR)/Makefile.debian install_debs
117         make -f $(DIR)/Makefile.debian test_for_libdbi_pkg
118         make -f $(DIR)/Makefile.common install_cpan
119         make -f $(DIR)/Makefile.common install_cpan_force
120         make -f $(DIR)/Makefile.common install_libdbi
121         make -f $(DIR)/Makefile.debian install_js_sm
122         make -f $(DIR)/Makefile.debian debian_sys_config
123
124 install_postgres_server:
125         make -f $(DIR)/Makefile.debian DEBS="$(PGSQL_SERVER_DEBS_93)"
126
127 # note: if/when grunt-cli and bower are available as 
128 # packages, use the packaged versions instead.
129 install_developer:
130         make -f $(DIR)/Makefile.debian DEBS="$(DEVELOPER_DEBS)"
131         npm update
132         npm install -g grunt-cli
133         npm install -g bower
134
135 install_packager:
136         make -f $(DIR)/Makefile.debian DEBS="$(PACKAGER_DEBS)"
137
138 clean:
139         make -f $(DIR)/Makefile.common clean
140         make -f $(DIR)/Makefile.debian clean
141
142 # vim:noet:sw=4:ts=4: