LP#1392759 developer/packager Makefile.install targets
[working/Evergreen.git] / Open-ILS / src / extras / install / Makefile.common
1 # Functions used by all installers
2
3 # Install the CPAN modules
4 install_cpan:
5         for m in $(CPAN_MODULES); do perl -MCPAN -e "install \"$$m\";"; done
6
7 install_cpan_force:
8         for m in $(CPAN_MODULES_FORCE); do \
9                 echo "force install $$m" | perl -MCPAN -e shell ;\
10         done
11
12 install_net_z3950_simpleserver:
13         if [ ! -f $(LIBNET_Z3950_SIMPLESERVER).tar.gz ]; \
14                 then wget $(LIBNET_Z3950_SIMPLESERVER_URL).tar.gz; \
15         fi;
16         tar -zxf $(LIBNET_Z3950_SIMPLESERVER).tar.gz
17         cd $(LIBNET_Z3950_SIMPLESERVER) && \
18                 perl Makefile.PL && make && make test && make install
19
20 # Install libdbi and the postgres drivers
21 install_libdbi:
22         if [ ! -d $(LIBDBI) ]; then wget $(LIBDBI_HOST)/$(LIBDBI).tar.gz; fi;
23         if [ ! -d $(LIBDBI_DRIVERS) ]; then wget $(LIBDBI_HOST)/$(LIBDBI_DRIVERS).tar.gz; fi;
24         tar -zxf $(LIBDBI).tar.gz
25         tar -zxf $(LIBDBI_DRIVERS).tar.gz
26         cd $(LIBDBI) && ./configure --disable-docs && make all install
27         cd $(LIBDBI_DRIVERS) && ./configure  \
28                 --disable-docs --with-pgsql --enable-libdbi && make all install  
29
30 # NOTE: Deprecate me with wheezy / precise
31 install_nodejs_from_source:
32         git clone https://github.com/joyent/node.git
33         cd node; \
34         git checkout -b $(NODEJS_SOURCE_VERSION) $(NODEJS_SOURCE_VERSION); \
35         ./configure && make && make install
36         npm update
37         npm install -g grunt-cli
38         npm install -g bower
39
40 clean:
41         make -C $(LIBDBI) clean
42         make -C $(LIBDBI_DRIVERS) clean
43         make -C $(LIBJS_PERL) clean
44
45 # vim:noet:sw=4:ts=4: