Add Business::OnlinePayment::PayPal CPAN dependency in Makefile.install.
[working/Evergreen.git] / Open-ILS / src / extras / Makefile.install
1 # ---------------------------------------------------------------------
2 # Author: Bill Erickson <erickson@esilibrary.com>
3 # Author: Dan Scott <dscott@laurentian.ca>
4 #
5 # Makefile to install prerequisites for OpenSRF and Evergreen
6 #
7 # Currently supports Debian (squeeze), Ubuntu (lucid), and Fedora (16).
8 # Working towards support of CentOS 5 / RHEL 5.
9 # Installs Perl prereqs, libjs with Perl wrapper, libdbi, libdbi-drivers, and libyaz
10 #
11 # usage:
12 #       make -f Makefile.install debian-squeeze
13 #       - or -
14 #       make -f Makefile.install ubuntu-lucid
15 #       - or -
16 #       make -f Makefile.install fedora16
17 #       - or -
18 #       make -f Makefile.install centos
19 #       - or -
20 #       make -f Makefile.install rhel
21 #
22 # Notes:
23 #
24 #       This makefile has been tested much more with Debian, Ubuntu, and
25 #       Fedora than CentOS, or RHEL.
26 #
27 # ---------------------------------------------------------------------
28  
29 # Make any assumptions about the shell being used explicit
30 SHELL=/bin/bash 
31
32 LIBJS=js-1.7.0
33 LIBJS_PERL=JavaScript-SpiderMonkey-0.20
34 LIBJS_URL=http://ftp.mozilla.org/pub/mozilla.org/js/$(LIBJS).tar.gz
35 LIBJS_PERL_URL=http://mirror.datapipe.net/pub/CPAN/authors/id/T/TB/TBUSCH/$(LIBJS_PERL).tar.gz
36 # used for installing libjs lib and header files
37 JS_INSTALL_PREFIX=/usr/
38
39 LIBNET_Z3950_SIMPLESERVER=Net-Z3950-SimpleServer-1.15
40 LIBNET_Z3950_SIMPLESERVER_URL=http://ftp.indexdata.dk/pub/simpleserver/$(LIBNET_Z3950_SIMPLESERVER)
41
42 # The libdbi sources can be fetched from sourceforge.net.  They are stored on
43 # the open-ils.org site now for ease of direct linking
44 LIBDBI=libdbi-0.8.3
45 LIBDBI_DRIVERS=libdbi-drivers-0.8.3
46 LIBDBI_HOST=http://open-ils.org/~denials/evergreen
47
48 # We need a recent version of Yaz
49 # Debian Lenny and Ubuntu 8.10 come with 3.0.34
50 YAZ=yaz-4.2.17
51 YAZ_HOST=http://ftp.indexdata.dk/pub/yaz
52
53 # Business::OnlinePayment is not packaged on CentOS/RHEL
54 PAY_ONLINE=Business-OnlinePayment-3.00_08.tar.gz
55 PAY_ONLINE_HOST=http://ftp.perl.org/pub/CPAN/authors/id/I/IV/IVAN/
56
57 APT_TOOL=aptitude -yq
58 APT_SAFE_TOOL=aptitude -P
59 APT_BACKPORT_TOOL=aptitude -t squeeze-backports -yq
60
61 # 64 or 32 bit os?
62 LBITS=$(shell getconf LONG_BIT)
63
64 # Fedora?
65 FEDORA=$(shell uname -r | grep "\.fc[0-9][0-9]\.")
66
67 # Fedora 64-bit?
68 FEDORA_64=$(shell uname -r | grep "\.fc[0-9][0-9]\.x86_64")
69
70 #RHEL/Centos PGSQL 
71 PGSQL_HOST=http://yum.pgsqlrpms.org/reporpms/9.0
72 PGSQL_CENTOS=pgdg-centos-9.0-2.noarch.rpm
73 PGSQL_REDHAT=pgdg-redhat-9.0-2.noarch.rpm       
74
75 # Debian dependencies
76 DEBS =  \
77         apache2-prefork-dev\
78         aspell\
79         aspell-en\
80         libbusiness-creditcard-perl\
81         libbusiness-onlinepayment-authorizenet-perl\
82         libbusiness-onlinepayment-perl\
83         libdatetime-format-builder-perl\
84         libdatetime-format-iso8601-perl\
85         libdatetime-format-mail-perl\
86         libdatetime-perl\
87         libdatetime-timezone-perl\
88         libdatetime-set-perl\
89         libdbd-pg-perl\
90         libemail-send-perl\
91         libemail-simple-perl\
92         libgd-graph3d-perl\
93         liblog-log4perl-perl\
94         libmarc-record-perl\
95         libncurses5-dev\
96         libnet-server-perl\
97         libnet-ssh2-perl\
98         libnspr4-dev\
99         libole-storage-lite-perl\
100         libparent-perl \
101         libreadline5-dev\
102         libspreadsheet-writeexcel-perl\
103         libssh2-1-dev\
104         libtext-aspell-perl\
105         libtext-csv-perl\
106         libuniversal-require-perl\
107         libnet-ip-perl\
108         liblocale-maketext-lexicon-perl\
109         libunix-syslog-perl
110
111 # Debian Lenny and Ubuntu Intrepid bundle recent versions of yaz
112 EXTRA_DEBS = \
113         libbusiness-isbn-perl\
114         libbusiness-isbn-data-perl\
115         libmarc-charset-perl \
116         libmarc-xml-perl \
117         libnet-z3950-zoom-perl \
118         libyaz-dev \
119         yaz
120
121 EXTRA_DEBS_SQUEEZE = \
122     libuuid-tiny-perl
123
124 EXTRA_DEBS_PRECISE = \
125     libdbi-dev \
126     libdbd-pgsql \
127     libmarc-record-perl \
128     libbusiness-edi-perl \
129     liblibrary-callnumber-lc-perl \
130     libsru-perl \
131     libnet-z3950-simple2zoom-perl \
132     libuuid-tiny-perl
133
134 # Ubuntu Hardy requires libencode-perl # to get a version of Encode
135 # > 2.12 - see bug 525069.
136 EXTRA_ENCODE = \
137         libencode-perl
138
139 CENTOS = \
140         aspell \
141         aspell-devel \
142         aspell-en \
143         gd-devel \
144         libssh2-devel \
145         openssl-devel \
146         perl-parent \
147         perl-Business-CreditCard \
148         perl-Business-ISBN \
149         perl-Business-ISBN-Data \
150         perl-Business-OnlinePayment \
151         perl-Class-Data-Inheritable \
152         perl-DateTime-Format-Builder \
153         perl-DateTime-Format-Strptime \
154         perl-Ima-DBI \
155         perl-DBD-Pg \
156         perl-GD-Graph3d \
157         perl-IO-stringy \
158         perl-Spreadsheet-WriteExcel \
159         perl-Text-Aspell \
160         perl-Text-CSV
161
162 CENTOS_PERL = \
163         Encode \
164         DBIx::ContextualFetch \
165         Getopt::Long \
166         Net::SSH2 \
167         Net::XMPP \
168         Net::Z3950::ZOOM
169
170 FEDORA_RPMS = \
171         aspell \
172         aspell-en \
173         libdbi \
174         libdbi-dbd-pgsql \
175         libdbi-devel \
176         libssh2-devel \
177         libyaz \
178         libyaz-devel \
179         mod_ssl \
180         ncurses-devel \
181         ncurses-libs \
182         perl-parent \
183         perl-Business-CreditCard \
184         perl-Business-ISBN \
185         perl-Business-ISBN-Data \
186         perl-DBD-Pg \
187         perl-Email-Send \
188         perl-Email-Simple \
189         perl-GDGraph3d \
190         perl-JSON-XS \
191         perl-Locale-Codes \
192         perl-Net-IP \
193         perl-Net-SSH2 \
194         perl-OLE-Storage_Lite \
195         perl-Spreadsheet-WriteExcel \
196         perl-Text-Aspell \
197         perl-Text-CSV \
198         perl-Text-CSV_XS \
199         perl-XML-Writer \
200         postgresql-devel \
201         readline-devel \
202         tcp_wrappers-devel \
203         wget \
204         yaz
205
206 # Note: B:O:AuthorizeNet 3.21 fails with https://rt.cpan.org/Public/Bug/Display.html?id=55172
207 # Should be fixed in 3.22
208 # MARC::Record 2.0.1 is required but only 2.0.0 is packaged
209 FEDORA_CPAN = \
210         Business::OnlinePayment \
211         Business::OnlinePayment::AuthorizeNet \
212         Business::OnlinePayment::PayPal \
213         MARC::Record \
214         UUID::Tiny
215
216 PGSQL_90_RPMS = \
217         postgresql90 \
218         postgresql90-contrib \
219         postgresql90-devel \
220         postgresql90-libs \
221         postgresql90-plperl \
222         postgresql90-server
223
224 PGSQL_FEDORA_RPMS = \
225         postgresql \
226         postgresql-contrib \
227         postgresql-libs \
228         postgresql-plperl \
229         postgresql-server
230
231 PGSQL_CLIENT_DEBS_90 = \
232         libpq5 \
233         libpq-dev \
234         postgresql-client-9.0
235
236 PGSQL_CLIENT_DEBS_91 = \
237         libpq5 \
238         libpq-dev \
239         postgresql-client-9.1
240
241 PGSQL_SERVER_DEBS_90 = \
242         postgresql-9.0 \
243         postgresql-contrib-9.0 \
244         postgresql-plperl-9.0 \
245         postgresql-server-dev-9.0
246
247 PGSQL_SERVER_DEBS_91 = \
248         postgresql-9.1 \
249         postgresql-contrib-9.1 \
250         postgresql-plperl-9.1 \
251         postgresql-server-dev-9.1
252
253 DEB_APACHE_MODS = \
254     expires\
255     include\
256     proxy\
257     proxy_http\
258     rewrite
259
260 DEB_APACHE_DISMODS = \
261     deflate
262
263 # Chronically unpackaged CPAN modules
264 CPAN_MODULES = \
265         Business::EDI \
266         Business::OnlinePayment::PayPal \
267         Library::CallNumber::LC \
268         Net::Z3950::Simple2ZOOM \
269         Template::Plugin::POSIX \
270         SRU
271
272 # More chronically unpackaged CPAN modules (available in Squeeze though)
273 CPAN_MODULES_MORE = \
274     Business::CreditCard::Object \
275     MARC::Record \
276     Net::SSH2 \
277     UUID::Tiny
278
279 # Are we sure most distros don't come with an acceptable version of Safe.pm?
280 CPAN_MODULES_SAFE = \
281         Safe
282
283 # Recent Debian/Ubuntus have libmarc-charset-perl, libmarc-xml-perl, libnet-z3950-zoom-perl
284 CPAN_MODULES_MARC = \
285         Business::ISBN \
286         Business::ISBN::Data \
287         MARC::Charset \
288         MARC::File::XML \
289         Net::Z3950::ZOOM
290
291 CPAN_MODULES_MARC_RECORD = \
292         MARC::Record
293
294 CPAN_MODULES_FORCE = \
295         Class::DBI::Frozen::301
296
297 # Lucid Lynx needs the following additional CPAN modules.
298 CPAN_MODULES_LUCID = \
299     RPC::XML::Function
300
301 # Precise Pangolin needs the following CPAN modules. All others are
302 # avaialalbe as debs.
303 CPAN_MODULES_PRECISE = \
304     Business::CreditCard::Object \
305     Business::OnlinePayment::PayPal \
306     Template::Plugin::POSIX \
307     RPC::XML::Function
308
309 # ----------------------------------------------------------------------------
310
311 all: 
312         @echo "please specify an OS" && exit 0
313
314 # these should be the same for any distro
315 install: install_cpan install_js_sm install_cpan_force
316
317 centos: install_centos_pgsql centos_like
318 rhel: install_redhat_pgsql centos_like
319 centos_like: install_centos_rpms install_yaz install_cpan_marc install install_centos_perl create_ld_local install_cpan_safe install_libdbi
320
321 fedora16: install_fedora_rpms install_cpan_fedora install_cpan_marc install
322
323 debian-squeeze: squeeze generic_debian
324 squeeze: install_pgsql_client_backport_debs_91  install_extra_debs_squeeze
325 generic_debian: install_debs install_yaz test_for_libdbi_pkg install debian_sys_config install_libdbi
326
327 # Needs for Ubuntu Lucid Lynx (10.04 LTS):
328 ubuntu-lucid: lucid generic_ubuntu
329 lucid: install_pgsql_client_debs_90 install_extra_debs \
330        install_cpan_marc_record install_yaz install_cpan_more \
331        install_cpan_safe install_cpan_lucid install test_for_libdbi_pkg \
332        install_libdbi
333
334 # Needs for Ubuntu Precise Pangolin (12.04 LTS):
335 ubuntu-precise: precise generic_ubuntu
336 precise: install_pgsql_client_debs_91 install_extra_debs_precise \
337          install_cpan_precise install_js_sm install_cpan_force
338
339 # We don't do the "install" target on generic_ubuntu because newer
340 # Ubuntu releases, like newer Debian releases, include packages for
341 # many of those prerequisites.
342 generic_ubuntu: install_debs debian_sys_config
343
344 # - COMMON TARGETS ---------------------------------------------------------
345
346 # Install the CPAN modules
347 install_cpan: install_net_z3950_simpleserver
348         for m in $(CPAN_MODULES); do perl -MCPAN -e "install \"$$m\";"; done
349
350 install_cpan_more: 
351         for m in $(CPAN_MODULES_MORE); do perl -MCPAN -e "install \"$$m\";"; done
352
353 # Install the CPAN modules for MARC functionality
354 install_cpan_marc: install_cpan_marc_record
355         for m in $(CPAN_MODULES_MARC); do perl -MCPAN -e "install \"$$m\";"; done
356
357 install_cpan_marc_record:
358         for m in $(CPAN_MODULES_MARC_RECORD); do perl -MCPAN -e "install \"$$m\";"; done
359
360 install_cpan_force:
361         for m in $(CPAN_MODULES_FORCE); do \
362                 echo "force install $$m" | perl -MCPAN -e shell ;\
363         done
364
365 # Install the Safe Perl module
366 # Is this really unpackaged everywhere except for Fedora?
367 install_cpan_safe: 
368         for m in $(CPAN_MODULES_SAFE); do perl -MCPAN -e "install \"$$m\";"; done
369
370 # Install the CPAN modules for Fedora
371 install_cpan_fedora: 
372         for m in $(FEDORA_CPAN); do \
373                 echo "force install $$m" | perl -MCPAN -e shell;\
374         done
375
376 # Install the CPAN modules needed for Lucid
377 install_cpan_lucid:
378         for m in $(CPAN_MODULES_LUCID); do perl -MCPAN -e "install \"$$m\";"; done
379
380 # Install the CPAN modules needed for Precise
381 install_cpan_precise:
382         for m in $(CPAN_MODULES_PRECISE); do perl -MCPAN -e "install \"$$m\";"; done
383
384 # Install a known working version of YAZ
385 install_yaz:    
386         if [ ! -d $(YAZ) ]; then wget $(YAZ_HOST)/$(YAZ).tar.gz; fi;
387         tar xzf $(YAZ).tar.gz
388         cd $(YAZ) && ./configure && make && make install && ldconfig
389
390 # Install the custom spidermonkey libs and JavaScript-SpiderMonkey Perl modules
391 install_js_sm: install_libjs install_spidermonkey
392
393 install_libjs: 
394         if [ ! -f $(LIBJS).tar.gz ]; then wget $(LIBJS_URL); fi;
395         tar -zxf $(LIBJS).tar.gz
396         cd js/src/ && JS_DIST=/usr make -f Makefile.ref
397         mkdir -p $(JS_INSTALL_PREFIX)/include/js/
398         cp js/src/*.h $(JS_INSTALL_PREFIX)/include/js/
399         cp js/src/*.tbl $(JS_INSTALL_PREFIX)/include/js/
400         if [ ! -z $(FEDORA_64) ]; then \
401                 cp js/src/Linux_All_DBG.OBJ/*.so $(JS_INSTALL_PREFIX)/lib64/ && \
402                 cp js/src/Linux_All_DBG.OBJ/*.a $(JS_INSTALL_PREFIX)/lib64/; \
403         else \
404                 cp js/src/Linux_All_DBG.OBJ/*.so $(JS_INSTALL_PREFIX)/lib/ && \
405                 cp js/src/Linux_All_DBG.OBJ/*.a $(JS_INSTALL_PREFIX)/lib/; \
406         fi;
407         ldconfig
408
409 install_spidermonkey:
410         if [ ! -f $(LIBJS_PERL).tar.gz ]; then wget $(LIBJS_PERL_URL); fi;
411         tar -zxf $(LIBJS_PERL).tar.gz
412         if [ ! -z $(FEDORA_64) ]; then \
413                 sed -i -e 's/"\/usr\/lib"/"\/usr\/lib64"/' $(LIBJS_PERL)/Makefile.PL ; \
414         fi;
415         if [ ! -z $(FEDORA) ]; then \
416                 sed -i -e 's/js32.dll/libjs.so/' $(LIBJS_PERL)/Makefile.PL ; \
417         fi;
418         cd $(LIBJS_PERL) && perl Makefile.PL -E4X && make && make test && make install
419
420 install_net_z3950_simpleserver:
421         if [ ! -f $(LIBNET_Z3950_SIMPLESERVER).tar.gz ]; then wget $(LIBNET_Z3950_SIMPLESERVER_URL).tar.gz; fi;
422         tar -zxf $(LIBNET_Z3950_SIMPLESERVER).tar.gz
423         cd $(LIBNET_Z3950_SIMPLESERVER) && perl Makefile.PL && make && make test && make install
424
425 # On Ubuntu and possibly Debian, the libdbi0 package prevents the 
426 # compiled-from-source version from being used and breaks the install.
427 # This package might get installed depending on the install-time choices
428 # for the distro. Test for its existence; if it's there, throw an error
429 # message and exit.
430 test_for_libdbi_pkg:
431                 @if [ "$$(apt-cache policy libdbi0 | grep Installed | grep none | wc -l)" -eq 0 ]; then \
432                                 echo "*** Detected locally installed libdbi0 package; you must remove this"; \
433                                 echo "*** with a command like 'aptitude remove libdbi0' before proceeding"; \
434                                 echo "*** to successfully install Evergreen."; \
435                                 echo; \
436                                 echo "*** Note: this may break other applications on your system."; \
437                                 exit 0; \
438                 fi;
439
440 # Install libdbi and the postgres drivers
441 install_libdbi:
442         if [ ! -d $(LIBDBI) ]; then wget $(LIBDBI_HOST)/$(LIBDBI).tar.gz; fi;
443         if [ ! -d $(LIBDBI_DRIVERS) ]; then wget $(LIBDBI_HOST)/$(LIBDBI_DRIVERS).tar.gz; fi;
444         tar -zxf $(LIBDBI).tar.gz
445         tar -zxf $(LIBDBI_DRIVERS).tar.gz
446         cd $(LIBDBI) && ./configure --disable-docs && make all install
447         cd $(LIBDBI_DRIVERS) && ./configure  \
448                 --disable-docs --with-pgsql --enable-libdbi && make all install  
449
450 clean:
451         make -C $(LIBDBI) clean
452         make -C $(LIBDBI_DRIVERS) clean
453         make -C $(LIBJS_PERL) clean
454         make -f Makefile.ref -C js/src/ clean
455
456
457 # ------------------------------------------------------------------
458 # - DEBIAN ---------------------------------------------------------
459
460 debian_sys_config: 
461         # link the apache modules in
462         for m in $(DEB_APACHE_MODS); do a2enmod $$m; done;
463         # keep the bad apache modules away
464         for m in $(DEB_APACHE_DISMODS); do a2dismod $$m; done;
465         # refresh the dynamic library cache
466         ldconfig
467
468 # Install the debian-specific dependencies
469 install_debs:
470         $(APT_TOOL) install $(DEBS)
471
472 install_pgsql_client_debs_90:
473         @if [ `$(APT_TOOL) versions libpq5 | grep ^i|sed 's/^i[ \t]*//'|cut -d. -f1` -eq 8 ]; \
474                 then \
475                 echo -e "libpq5 / libpq-dev are installed as part of OpenSRF (a dependency" \
476                 "of apache2-prefork-dev), but these are the 8.4 versions and they" \
477                 "conflict with the 9.0 versions - so remove them, install the pinned" \
478                 "backports of 9.0, then reinstall the apache2-prefork-dev package.\n\n" \
479                 "**WARNING**: Saying 'Yes' to this step will _remove_ any PostgreSQL" \
480                 "databases that might currently exist on this machine." && \
481                 $(APT_SAFE_TOOL) remove libpq5 libpq-dev ; \
482         fi
483         $(APT_BACKPORT_TOOL) install $(PGSQL_CLIENT_DEBS_90)
484         $(APT_TOOL) install apache2-prefork-dev
485
486 install_pgsql_server_debs_90:
487         $(APT_BACKPORT_TOOL) install $(PGSQL_SERVER_DEBS_90)
488
489 install_pgsql_client_backport_debs_91:
490         @if [ `$(APT_TOOL) versions libpq5 | grep ^i|sed 's/^i[ \t]*//'|cut -d. -f1` -eq 8 ]; \
491                 then \
492                 echo -e "libpq5 / libpq-dev are installed as part of OpenSRF (a dependency" \
493                 "of apache2-prefork-dev), but these are the 8.4 versions and they" \
494                 "conflict with the 9.0 versions - so remove them, install the pinned" \
495                 "backports of 9.0, then reinstall the apache2-prefork-dev package.\n\n" \
496                 "**WARNING**: Saying 'Yes' to this step will _remove_ any PostgreSQL" \
497                 "databases that might currently exist on this machine." && \
498                 $(APT_SAFE_TOOL) remove libpq5 libpq-dev ; \
499         fi
500         $(APT_BACKPORT_TOOL) install $(PGSQL_CLIENT_DEBS_91)
501         $(APT_TOOL) install apache2-prefork-dev
502
503 install_pgsql_client_debs_91:
504         $(APT_TOOL) install $(PGSQL_CLIENT_DEBS_91)
505
506 install_pgsql_server_debs_91:
507         $(APT_BACKPORT_TOOL) install $(PGSQL_SERVER_DEBS_91)
508
509 # Install the debian-specific dependencies for more modern distros
510 install_extra_debs_squeeze: install_extra_debs
511         $(APT_TOOL) install $(EXTRA_DEBS_SQUEEZE)
512
513 # Install dependencies for Ubuntu 12.04:
514 install_extra_debs_precise: install_extra_debs
515         $(APT_TOOL) install $(EXTRA_DEBS_PRECISE)
516
517 install_extra_debs:
518         $(APT_TOOL) install $(EXTRA_DEBS)
519
520 # Install specific modules required by Ubuntu Hardy - see bug 525069
521 install_extra_encode:
522         $(APT_TOOL) install $(EXTRA_ENCODE)
523
524 # ------------------------------------------------------------------
525
526 # FEDORA
527 install_fedora_rpms:
528         yum -y update
529         yum -y install $(FEDORA_RPMS)
530
531 install_fedora_pgsql_server:
532         yum -y install $(PGSQL_FEDORA_RPMS)
533
534 # CENTOS
535 install_centos_rpms:
536         yum -y install $(CENTOS)
537         yum -y update
538         if [ $(LBITS) -eq 64 ]; then \
539                 ln -sf /usr/lib64/libpq.* /usr/lib/ && \
540                 ln -sf /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/libperl.so /usr/lib/ && \
541                 ldconfig ; \
542         fi;
543         if [ $(LBITS) -eq 32 ]; then \
544                 ln -sf /usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so /usr/lib && \
545                 ldconfig ; \
546         fi;
547
548 install_centos_pgsql:
549         if [ $(LBITS) -eq 64 ]; then yum remove -y postgresql-libs-8.1*i386 apr-util-devel-*i386 ; fi;
550         wget $(PGSQL_HOST)/$(PGSQL_CENTOS)
551         rpm -Uvh --force ./$(PGSQL_CENTOS)
552         yum update -y
553         yum -y install $(PGSQL_90_RPMS)
554
555 install_redhat_pgsql:
556         if [ $(LBITS) -eq 64 ]; then yum remove -y postgresql-libs-8.1*i386 apr-util-devel-*i386 ; fi;
557         wget $(PGSQL_HOST)/$(PGSQL_REDHAT)
558         rpm -Uvh --force ./$(PGSQL_REDHAT)
559         yum update -y
560         yum -y install $(PGSQL_90_RPMS)
561
562 install_centos_perl:
563         for m in $(CENTOS_PERL); do perl -MCPAN -e "install \"$$m\";"; done
564         echo "force install Business::OnlinePayment::AuthorizeNet" | perl -MCPAN -e shell
565         echo "force install Scalar::Util" | perl -MCPAN -e shell        
566
567 # We need to add /usr/local/lib to the ldconfig list of directories on CentOS,
568 # if it is not already there
569 create_ld_local:
570         if [ "$$(ldconfig -v 2> /dev/null | grep '^/usr/local/lib' | wc -l)" -eq 0 ]; then \
571                 echo '/usr/local/lib' >> /etc/ld.so.conf.d/local.conf; \
572                 ldconfig; \
573         fi;
574
575 # vim:noet:sw=4:ts=4: