LP#1559121: remove Debian Squeeze support
authorGalen Charlton <gmc@esilibrary.com>
Fri, 18 Mar 2016 14:59:11 +0000 (10:59 -0400)
committerBen Shum <ben@evergreener.net>
Sat, 23 Apr 2016 02:06:58 +0000 (22:06 -0400)
Now that Debian Squeeze's LTS (long-term support) period
has ended, Evergreen no longer offers community support
for that distribution. This patch removes references
to Squeeze from the installation scripts and documentation.

To test:

[1] Verify that Debian Squeeze is no longer referenced in
    the installation documentation.

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Ben Shum <ben@evergreener.net>
README
src/extras/Makefile.install

diff --git a/README b/README
index a5895c0..9fe63a0 100644 (file)
--- a/README
+++ b/README
@@ -42,7 +42,6 @@ Well-tested values for <osname> include:
 
   * `debian-jessie` for Debian 8.0
   * `debian-wheezy` for Debian 7.0
 
   * `debian-jessie` for Debian 8.0
   * `debian-wheezy` for Debian 7.0
-  * `debian-squeeze` for Debian 6.0
   * `ubuntu-precise` for Ubuntu 12.04
   * `ubuntu-trusty` for Ubuntu 14.04
   * `fedora` for Fedora 17 and later
   * `ubuntu-precise` for Ubuntu 12.04
   * `ubuntu-trusty` for Ubuntu 14.04
   * `fedora` for Fedora 17 and later
index dbb21ae..604306b 100644 (file)
@@ -4,7 +4,7 @@
 #
 # Makefile to install prerequisites for OpenSRF
 #
 #
 # Makefile to install prerequisites for OpenSRF
 #
-# Currently supports Debian (jessie/wheezy/squeeze), Ubuntu (precise/trusty)
+# Currently supports Debian (jessie/wheezy), Ubuntu (precise/trusty)
 # and Fedora (16).
 #
 # Installs Perl prereqs, libjs with Perl wrapper
 # and Fedora (16).
 #
 # Installs Perl prereqs, libjs with Perl wrapper
@@ -14,8 +14,6 @@
 #      - or -
 #      make -f Makefile.install debian-wheezy
 #      - or -
 #      - or -
 #      make -f Makefile.install debian-wheezy
 #      - or -
-#      make -f Makefile.install debian-squeeze
-#      - or -
 #      make -f Makefile.install ubuntu-precise
 #      - or -
 #      make -f Makefile.install ubuntu-trusty
 #      make -f Makefile.install ubuntu-precise
 #      - or -
 #      make -f Makefile.install ubuntu-trusty
@@ -153,12 +151,6 @@ EXTRA_DEBS = \
        libjson-xs-perl \
        libnet-server-perl
 
        libjson-xs-perl \
        libnet-server-perl
 
-EXTRA_DEBS_SQUEEZE = \
-       libmemcached-dev \
-       libmemcached-tools \
-       libxml-libxml-perl \
-       libxml-libxslt-perl
-
 EXTRA_DEBS_WHEEZY = \
        libmemcached-dev \
        libmemcached-tools \
 EXTRA_DEBS_WHEEZY = \
        libmemcached-dev \
        libmemcached-tools \
@@ -193,10 +185,8 @@ all:
 
 debian-jessie: generic_debian jessie
 debian-wheezy: generic_debian wheezy
 
 debian-jessie: generic_debian jessie
 debian-wheezy: generic_debian wheezy
-debian-squeeze: generic_debian squeeze
 jessie: install_extra_debs_jessie apache_mpm_prefork_mods
 wheezy: install_extra_debs_wheezy
 jessie: install_extra_debs_jessie apache_mpm_prefork_mods
 wheezy: install_extra_debs_wheezy
-squeeze: install_extra_debs_squeeze
 generic_debian: install_debs debian_sys_config
 
 fedora: install_fedora_rpms
 generic_debian: install_debs debian_sys_config
 
 fedora: install_fedora_rpms
@@ -234,9 +224,6 @@ install_extra_debs_jessie: install_extra_debs
 install_extra_debs_wheezy: install_extra_debs
        $(APT_TOOL) install $(EXTRA_DEBS_WHEEZY)
 
 install_extra_debs_wheezy: install_extra_debs
        $(APT_TOOL) install $(EXTRA_DEBS_WHEEZY)
 
-install_extra_debs_squeeze: install_extra_debs
-       $(APT_TOOL) install $(EXTRA_DEBS_SQUEEZE)
-
 # Install even more packaged dependencies on modern distros
 install_extra_debs_precise:
        $(APT_TOOL) install $(EXTRA_DEBS_UBUNTU_PRECISE)
 # Install even more packaged dependencies on modern distros
 install_extra_debs_precise:
        $(APT_TOOL) install $(EXTRA_DEBS_UBUNTU_PRECISE)