Comment out an error message added in the previous patch.
authorscottmk <scottmk@9efc2488-bf62-4759-914b-345cdb29e865>
Tue, 29 Sep 2009 03:58:13 +0000 (03:58 +0000)
committerscottmk <scottmk@9efc2488-bf62-4759-914b-345cdb29e865>
Tue, 29 Sep 2009 03:58:13 +0000 (03:58 +0000)
The error message reported what looks like an error condition:
the config file doesn't provide transport info.  However what
appears to be happening is that the program tries to read
several different sections of the config file, of which some
are relevant and some aren't, due to some overloading of the
<routers> tag.  As a result it routinely spawns irrelevant
children, only to watch them die.

There's got to be a better way, but for now I'll just
suppress the error message.

M    src/router/osrf_router_main.c

git-svn-id: svn://svn.open-ils.org/OpenSRF/trunk@1800 9efc2488-bf62-4759-914b-345cdb29e865

src/router/osrf_router_main.c

index 9630f29..7e39a18 100644 (file)
@@ -115,7 +115,7 @@ static void setupRouter(jsonObject* configChunk) {
 
        jsonObject* transport_cfg = jsonObjectGetKey( configChunk, "transport" );
        if( ! transport_cfg ) {
 
        jsonObject* transport_cfg = jsonObjectGetKey( configChunk, "transport" );
        if( ! transport_cfg ) {
-               fprintf( stderr, "Child router process %ld has no transport configuration\n", (long) getpid() );
+               //fprintf( stderr, "Child router process %ld has no transport configuration\n", (long) getpid() );
                return; /* these are not the configs you're looking for */
        }
 
                return; /* these are not the configs you're looking for */
        }