It's so alluring to install packages instead of compiling from source, except when...
authordbs <dbs@9efc2488-bf62-4759-914b-345cdb29e865>
Thu, 4 Dec 2008 02:40:32 +0000 (02:40 +0000)
committerdbs <dbs@9efc2488-bf62-4759-914b-345cdb29e865>
Thu, 4 Dec 2008 02:40:32 +0000 (02:40 +0000)
git-svn-id: svn://svn.open-ils.org/OpenSRF/trunk@1517 9efc2488-bf62-4759-914b-345cdb29e865

src/extras/Makefile.install

index aef0043..e768bd4 100644 (file)
@@ -203,14 +203,19 @@ EXTRA_DEBS = \
 # generic CPAN modules:
 #   * DateTime::Format::ISO8601 is packaged by both Debian Lenny and Ubuntu Intrepid
 #   * JSON::XS is packaged by both Debian Lenny and Ubuntu Intrepid
-#   * XML::LibXML::XPathContext is part of libxml-libxml-perl on Debian Lenny and Ubuntu Intrepid
 #   * libnet-server-perl 0.97 is packaged on Debian Lenny and Ubuntu Intrepid
 #     - is there a specific need for 0.90?
 CPAN_MODULES = \
        DateTime::Format::ISO8601 \
        RHANDOM/Net-Server-0.90.tar.gz \
-       JSON::XS \
-       XML::LibXML::XPathContext
+       JSON::XS
+
+#   libxml-libxml-perl on Debian Lenny and Ubuntu Intrepid is 1.66, which
+#   has broken namespace handling. so we still need to install these from
+#   CPAN. *sigh*
+CPAN_MODULES_XML = \
+       XML::LibXML \
+       XML::LibXSLT
 
 # generic CPAN modules to force
 CPAN_MODULES_FORCE = \
@@ -228,7 +233,7 @@ debian-etch: generic_debian etch
 debian-lenny: generic_debian lenny
 etch: install_cpan
 lenny: install_extra_debs
-generic_debian: install_debs install_cpan_force debian_sys_config
+generic_debian: install_debs install_cpan_force install_cpan_xml debian_sys_config
 
 gentoo: install_gentoos install_gentoo_rc install_gentoo_perl install
 
@@ -239,7 +244,7 @@ ubuntu-hardy: generic_ubuntu hardy
 ubuntu-intrepid: generic_ubuntu intrepid
 hardy: install_cpan
 intrepid: install_extra_debs
-generic_ubuntu: install_debs install_cpan_force debian_sys_config
+generic_ubuntu: generic_debian
 
 # - COMMON TARGETS ---------------------------------------------------------
 
@@ -251,6 +256,10 @@ install_cpan:
 install_cpan_force: 
        for m in $(CPAN_MODULES_FORCE); do perl -MCPAN -e "CPAN::Shell->force(qw#install $$m#);"; done
 
+# Install the CPAN XML modules
+install_cpan_xml: 
+       for m in $(CPAN_MODULES_XML); do perl -MCPAN -e "install \"$$m\";"; done
+
 # Install ejabberd from official project installer binary
 install_ejabberd:    
        if [ ! -f $(EJABBERD_PKG).gz ]; then wget $(EJABBERD_HOST)/$(EJABBERD_VER)/$(EJABBERD_PKG).gz; fi;