Move on up to Lucid; drop Karmic along the way
[OpenSRF.git] / src / extras / Makefile.install
index 13b0379..9ec98f2 100644 (file)
@@ -3,7 +3,7 @@
 #
 # Makefile to install prerequisites for OpenSRF
 #
-# Currently supports Debian (etch/lenny), Ubuntu (hardy/karmic), and Gentoo.
+# Currently supports Debian (etch/lenny), Ubuntu (hardy/lucid), and Gentoo.
 # Working towards support of CentOS 5 / RHEL 5 and Fedora.
 # Installs Perl prereqs, libjs with Perl wrapper
 #
@@ -14,7 +14,7 @@
 #      - or -
 #      make -f Makefile.install ubuntu-hardy
 #      - or -
-#      make -f Makefile.install ubuntu-karmic
+#      make -f Makefile.install ubuntu-lucid
 #      - or -
 #      make -f Makefile.install centos
 #      - or -
@@ -289,7 +289,7 @@ EXTRA_DEBS = \
        libjson-xs-perl \
        libnet-server-perl
 
-EXTRA_DEBS_UBUNTU_KARMIC = \
+EXTRA_DEBS_UBUNTU_LUCID = \
        libmemcached-dev\
        libxml-libxml-perl \
        libxml-libxslt-perl
@@ -336,9 +336,9 @@ gentoo: install_gentoos install_gentoo_rc install_gentoo_perl install
 rhel: centos
 
 ubuntu-hardy: generic_ubuntu install_cpan_xml hardy
-ubuntu-karmic: generic_ubuntu karmic
+ubuntu-lucid: generic_ubuntu lucid
 hardy: install_cpan install_libmemcached 
-karmic: install_extra_debs install_extra_debs_karmic
+lucid: install_extra_debs install_extra_debs_lucid
 generic_ubuntu: install_debs install_cpan_force debian_sys_config
 
 # - COMMON TARGETS ---------------------------------------------------------
@@ -452,8 +452,8 @@ install_extra_debs:
        $(APT_TOOL) install $(EXTRA_DEBS)
 
 # Install even more packaged dependencies on modern distros
-install_extra_debs_karmic:
-       $(APT_TOOL) install $(EXTRA_DEBS_UBUNTU_KARMIC)
+install_extra_debs_lucid:
+       $(APT_TOOL) install $(EXTRA_DEBS_UBUNTU_LUCID)
 
 # ------------------------------------------------------------------
 # - GENTOO ---------------------------------------------------------