]> git.evergreen-ils.org Git - OpenSRF.git/blob - src/ports/strn_compat/Makefile
providing option to connect to memcache at general connect time
[OpenSRF.git] / src / ports / strn_compat / Makefile
1 # OSRF_LOG_PARAMS log all incoming method params at OSRF_INFO log level. 
2 # OSRF_STRICT_PARAMS instructs the app handler to return an error if the number of method arguments
3 #       provided to any method is not at least as large as the 'argc' setting for the method
4
5 CFLAGS  +=  -rdynamic -fno-strict-aliasing -fPIC
6
7 TARGETS = strndup.o strnlen.o
8 HEADERS = strndup.h strnlen.h
9
10 all: libfreebsd_str_compat.so $(TARGETS)
11
12 libfreebsd_str_compat.so: $(TARGETS)
13         $(CC) -shared -W1 $(TARGETS) -o $@
14
15 strndup.o:      strndup.c strndup.h
16 strnlen.o:      strnlen.c strnlen.h
17
18 clean:
19         /bin/rm -f *o
20