dropping all support for 8.0 with 1.4 and beyond