Add libmemcache and ncurses dependencies on CentOS/RHEL
authordbs <dbs@dcc99617-32d9-48b4-a31d-7c20da2025e4>
Tue, 24 Jun 2008 15:25:20 +0000 (15:25 +0000)
committerdbs <dbs@dcc99617-32d9-48b4-a31d-7c20da2025e4>
Tue, 24 Jun 2008 15:25:20 +0000 (15:25 +0000)
git-svn-id: svn://svn.open-ils.org/ILS/trunk@9918 dcc99617-32d9-48b4-a31d-7c20da2025e4

Open-ILS/src/extras/Makefile.install

index 5c6dbca..345142c 100644 (file)
@@ -58,6 +58,10 @@ EJABBERD_VER=2.0.1
 EJABBERD_PKG=ejabberd-2.0.1_2-linux-x86-installer.bin
 EJABBERD_HOST=http://www.process-one.net/downloads/ejabberd
 
+# libmemcache is not packaged on CentOS/RHEL
+LIBMEMCACHE=libmemcache-1.4.0.rc2
+LIBMEMCACHE_HOST=http://people.freebsd.org/~seanc/libmemcache/
+
 # Business::OnlinePayment is not packaged on CentOS/RHEL
 PAY_ONLINE=Business-OnlinePayment-3.00_08.tar.gz
 PAY_ONLINE_HOST=http://ftp.perl.org/pub/CPAN/authors/id/I/IV/IVAN/
@@ -150,6 +154,8 @@ CENTOS = \
        make \
        mod_perl \
        mod_ssl \
+       ncurses \
+       ncurses-devel \
        ntp \
        perl-DBD-Pg \
        perl-DBI \
@@ -304,7 +310,8 @@ all:
 # these should be the same for any distro
 install: install_yaz install_cpan install_js_sm install_libdbi 
 
-centos: install_centos_pgsql install_centos_rpms install_ejabberd install install_libxml2 install_libxslt install_centos_perl 
+centos: install_centos_pgsql install_centos_rpms install_ejabberd install_libmemcache install install_libxml2 install_libxslt install_centos_perl 
+
 debian: install_pgsql_debian install_debs install debian_sys_config
 
 gentoo: install_gentoos install_gentoo_rc install_gentoo_perl install
@@ -327,6 +334,12 @@ install_ejabberd:
        chmod u+x $(EJABBERD_PKG).gz
        ./$(EJABBERD_PKG) --mode unattended --prefix /opt/ejabberd --adminpw evergreen
 
+# Install libmemcache from the official project source
+install_libmemcache:
+       if [ ! -d $(LIBMEMCACHE) ]; then wget $(LIBMEMCACHE_HOST)/$(LIBMEMCACHE).tar.bz2; fi;
+       tar xjf $(LIBMEMCACHE).tar.bz2
+       cd $(LIBMEMCACHE) && ./configure && make && make install
+
 # Install a newer version of libxslt
 install_libxslt:    
        if [ ! -d $(XSLT) ]; then wget $(XSLT_HOST)/$(XSLT).tar.gz; fi;