warn if libdbi is not found by "locate"
[Evergreen.git] / Open-ILS / src / support-scripts / settings-tester.pl
index 342ff4f..5b51713 100755 (executable)
@@ -243,6 +243,11 @@ sub test_db_connect {
 sub check_libdbd {
        my $results = '';
        my @location = `locate libdbdpgsql.so | grep -v home | grep -v .libs`; # simple(ton) attempt to filter out build versions
+    unless(@location) {
+        my $res = "Libdbi postgres driver not found\n";
+        print $res;
+        return $res;
+    }
        if (scalar(@location) > 1) {
 
                my $res = "Found more than one location for libdbdpgsql.so.