9f67c14d19a008bfa1d28c526dd6fe44c21bbc49
[Evergreen.git] / Open-ILS / src / extras / install / Makefile.ubuntu-xenial
1 # install files for Ubuntu Xenial
2
3 DIR = $(dir $(lastword $(MAKEFILE_LIST)))
4
5 export DEB_PGSQL_COMMON_MODS = \
6         gcc \
7         libbusiness-isbn-perl \
8         libjson-xs-perl \
9         liblibrary-callnumber-lc-perl \
10         libmarc-record-perl \
11         libmarc-xml-perl \
12         librose-uri-perl \
13         libuuid-tiny-perl \
14         libxml-libxml-perl \
15         libxml-libxslt-perl
16
17 export DEBS = \
18         $(DEB_PGSQL_COMMON_MODS) \
19         apache2-dev\
20         aspell\
21         aspell-en\
22         libapache2-mod-perl2\
23         libbusiness-creditcard-perl\
24         libbusiness-isbn-data-perl\
25         libbusiness-issn-perl\
26         libbusiness-onlinepayment-authorizenet-perl\
27         libbusiness-onlinepayment-payflowpro-perl\
28         libbusiness-onlinepayment-perl\
29         libdate-manip-perl\
30         libdatetime-format-builder-perl\
31         libdatetime-format-iso8601-perl\
32         libdatetime-format-mail-perl\
33         libdatetime-perl\
34         libdatetime-set-perl\
35         libdatetime-timezone-perl\
36         libdbd-pg-perl\
37         libdbd-pgsql\
38         libdbi-dev\
39         libdbi1\
40         libemail-simple-perl\
41         libemail-mime-perl\
42         libexcel-writer-xlsx-perl\
43         libgd-graph3d-perl\
44         liblocale-maketext-lexicon-perl\
45         liblog-log4perl-perl\
46         libmarc-charset-perl \
47         libncurses5-dev\
48         libnet-ip-perl\
49         libnet-ldap-perl \
50         libnet-server-perl\
51         libnet-ssh2-perl\
52         libnet-z3950-simple2zoom-perl\
53         libnet-z3950-simpleserver-perl\
54         libnet-z3950-zoom-perl \
55         libnspr4-dev\
56         libole-storage-lite-perl\
57         libparent-perl\
58         libpq5\
59         libpq-dev\
60         libpcre3-dev\
61         librpc-xml-perl\
62         libsru-perl\
63         libssh2-1-dev\
64         libtemplate-plugin-posix-perl\
65         libtest-warn-perl\
66         libtest-output-perl\
67         libtext-aspell-perl\
68         libtext-csv-perl\
69         libuniversal-require-perl\
70         libunix-syslog-perl\
71         libyaz-dev\
72         postgresql-client-9.6\
73         libsoap-lite-perl\
74         libbz2-dev\
75         libparse-recdescent-perl\
76         libhtml-defang-perl\
77         libconfig-general-perl\
78         yaz
79
80 export DEB_APACHE_MODS = \
81     expires\
82     include\
83     proxy\
84     proxy_http\
85     rewrite\
86     cgi\
87     perl\
88     remoteip
89
90 export DEB_APACHE_DISMODS = \
91     deflate
92
93 export DEB_APACHE_DISCONF = \
94     serve-cgi-bin
95
96 export CPAN_MODULES = \
97         Business::OnlinePayment::PayPal \
98         Email::Send
99
100 export CPAN_MODULES_FORCE = \
101         Business::Stripe \
102         Class::DBI::Frozen::301
103
104 PGSQL_SERVER_DEBS_96 = \
105         $(DEB_PGSQL_COMMON_MODS) \
106         postgresql-9.6 \
107         postgresql-contrib-9.6 \
108         postgresql-plperl-9.6 \
109         postgresql-server-dev-9.6
110
111 PGSQL_SERVER_DEBS_10 = \
112         $(DEB_PGSQL_COMMON_MODS) \
113         postgresql-10 \
114         postgresql-contrib-10 \
115         postgresql-plperl-10 \
116         postgresql-server-dev-10
117
118 # note: some prereqs are repeated in the developer/packager 
119 # sections to support building Evergreen packages on servers
120 # where Evergreen and its prereqs are not installed.
121
122 DEVELOPER_DEBS = \
123         automake \
124         autoconf \
125         libtool \
126         chromium-browser \
127         firefox
128
129 PACKAGER_DEBS = \
130         asciidoc \
131         source-highlight \
132         zip \
133         unzip \
134         nsis
135
136 TRANSLATOR_DEBS = \
137         libtemplate-perl \
138         liblocale-maketext-lexicon-perl \
139         translate-toolkit \
140         python-dev \
141         python-levenshtein \
142         python-polib \
143         python-setuptools \
144         python-simplejson \
145         python-lxml \
146         bzr
147
148 all:
149         make -f $(DIR)/Makefile.debian DEBS="$(PGSQL_APT_REPO_DEBS)"
150         make -f $(DIR)/Makefile.debian debian_postgresql_repo
151         make -f $(DIR)/Makefile.debian install_debs
152         make -f $(DIR)/Makefile.common install_cpan
153         make -f $(DIR)/Makefile.common install_cpan_force
154         make -f $(DIR)/Makefile.debian debian_sys_config
155
156 install_postgres_server:
157         make -f $(DIR)/Makefile.debian DEBS="$(PGSQL_APT_REPO_DEBS)"
158         make -f $(DIR)/Makefile.debian debian_postgresql_repo
159         make -f $(DIR)/Makefile.debian DEBS="$(PGSQL_SERVER_DEBS_96)"
160
161 install_postgres_server_10:
162         make -f $(DIR)/Makefile.debian DEBS="$(PGSQL_APT_REPO_DEBS)"
163         make -f $(DIR)/Makefile.debian debian_postgresql_repo
164         make -f $(DIR)/Makefile.debian DEBS="$(PGSQL_SERVER_DEBS_10)"
165
166 # note: if/when grunt-cli is available as a
167 # package, use the packaged version instead.
168 install_developer:
169         make -f $(DIR)/Makefile.debian DEBS="$(DEVELOPER_DEBS)"
170         make -f $(DIR)/Makefile.common install_nodejs_from_source
171
172 install_translator: install_developer
173         make -f $(DIR)/Makefile.debian DEBS="$(TRANSLATOR_DEBS)"
174
175 install_packager: install_developer install_translator
176         make -f $(DIR)/Makefile.debian DEBS="$(PACKAGER_DEBS)"
177
178 clean:
179         make -f $(DIR)/Makefile.common clean
180         make -f $(DIR)/Makefile.debian clean
181
182 # vim:noet:sw=4:ts=4: