Lp 1732485: Update README for bug work around. master
authorJason Stephenson <jason@sigio.com>
Wed, 15 Nov 2017 16:32:44 +0000 (11:32 -0500)
committerJason Stephenson <jason@sigio.com>
Wed, 15 Nov 2017 16:32:44 +0000 (11:32 -0500)
Add warning about the bug and suggest that the patch on that bug be
applied to /usr/share/perl5/HTTP/Body/XForms.pm.

Signed-off-by: Jason Stephenson <jason@sigio.com>

README

diff --git a/README b/README
index 58fe229..08977d2 100644 (file)
--- a/README
+++ b/README
@@ -24,6 +24,22 @@ other distributions will need to install the equivalent packages.
 * libxml-libxml-simple-perl
 * libplack-perl
 
+[WARNING]
+If you are installing on a recent, supported distribution, i.e. Ubuntu
+16.04, Debian 8 Jessie, or Debian 9 Stretch, you should be aware of
+https://bugs.launchpad.net/ncipserver/+bug/1732485[this bug].  You
+will very likely need to apply the patch on that bug to have a working
+NCIPServer installation.
+
+After installing the prerequisites above and downloading the patch,
+you can apply it with the following command:
+
+[source,sh]
+sudo patch -b /usr/share/perl5/HTTP/Body/XForms.pm /path/to/HTTP-Body-XForms.patch
+
+NOTE: The path to /usr/share/perl5/HTTP/Body/XForms.pm may vary by
+Linux distribution.
+
 Installation
 ------------